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1.1 System Requirements

The minimum system requirements for running MaxView are:

- Microsoft© Windows XP or Windows 2000
- 500MHz Intel© Pentium III or equivalent
- 128MB RAM
- 1024 x 768, 24-bit colour graphics card
- 2 x USB1.1 or 2.0 port
- Approx. 60MB hard disk space per hour acquiring

1.2 Installing MaxView

MaxView should install automatically when you insert the MaxView CD into your CD
drive. If the software does not install automatically you can run the installation file from
the start menu.

If the software does not install automatically:

- Select 'Run...' from the 'Start' menu
- Type 'D:\setup.exe' (D is the letter of your CD drive)
- Click 'OK' to start the installation
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1.3 Installing the STR driver

Before using the MaxView with the STR, the STR driver must be installed .

To install the STR driver run the file 'CDM 2.04.06.exe' supplied on the MaxView CD.
This should be done before the STR is connected to the USB port.
  

1.4 The MaxView Dongle

Before you can acquire sidescan records using MaxView the supplied security dongle
must be plugged into a USB port on the PC.

When the dongle is not present all features except acquisition are stilll available. This
allows the installation of MaxView on multiple PCs for offline processing.

!Take care not to lose or damage the dongle. Replacement
dongles will only be provided under certain circumstances!

1.5 Installing the Dongle driver

Before using the MaxView the dongle driver must be installed on any computer that is to
be used for data acquisition.

If the dongle driver was not installed during the MaxView installation process it can be
done manually be running the file 'HASPUserSetup.exe' supplied on the MaxView CD.
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2.1 What does MaxView do?

C-MAX MaxView is used in conjunction with the CM2 Sonar Transceiver (STR) and
Towfish to acquire, display and process side scan sonar data. It can accept position
and depth information from sensors such as GPS recievers and echo sounders.

Features include:

Data acquisition from the CM2 towfish and STR via the USB interface on any PC
eliminating the need for A/D boards or other specialized hardware.

Simultaneous display of live and previously recorded data.

Auto scaling plotter showing vessel track, sidescan coverage, survey plan, targets
and chart imagery.

Survey planning with helm indication.

Online or offline geo-referenced target marking.
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2.2 The MaxView Display
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2.3 MaxView projects

A MaxView project is a collection of CM2 side scan sonar records, user generated
targets and survey planning lines. A project may contain up to 100 records and up to
256 targets. TO VIEW OR ACQUIRE RECORDS IN MAXVIEW YOU MUST FIRST
EITHER CREATE OR OPEN A PROJECT.

The records, targets and survey plans in a project are listed in the 'Records', 'Targets'
and 'Survey' tabs displayed in the lower part of the screen.

Creating a new project

To create a new project select File > New Project.

You will be asked for a project name and a project folder. The project folder will be used
to store the project description file and any acquired records. If the 'Auto save project
changes' box is ticked the project description file will be updated and saved when any
change is made to the current project.

Opening a project

To open a project select File > Open Project....

MaxView project description files have the extension '.CMP'.  Note that a project
description file contains only links to sidescan records. They do not contain any imagery
data themselves. If a record specified in a project file has been moved or deleted
MaxView will prompt you for its new location.

The four most recently opened projects are shown in the File menu. You can quickly
open these projects by selecting them from this menu.

Adding records to a project

To add records to a project select File > Add Records To Project....  CM2 records have
the he extension '.CM2'. You can also drag and drop CM2 records into the MaxView
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window. If the selected records are not in the current project folder you will be asked if
you wish to move these files into the project folder.

Removing records from a project

To remove records to a project select the records to be removed in the records tab and
select File > Remove Selected Records. If you remove a record which has targets
associated with it the targets will also be removed from the project. WHEN A RECORD
IS REMOVED FROM A PROJECT THE IMAGERY FILE WILL NOT BE DELETED
FROM THE COMPUTER. IT CAN ALWAYS BE SUBSEQUENTLY ADDED TO TO
THE CURRENT OR OTHER PROJECT.
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3.1 Starting and stopping the towfish

Starting the towfish

To start the towfish select Towfish > Start.... The dialog below indicates the progress of
the starting sequence.

The starting sequence has four phases:

Initializing - MaxView is instructing the Sonar Transceiver Unit to start the towfish.

Energising - The Sonar Transceiver Unit is powering up the towfish circuitry.

Connecting - Sonar Transceiver Unit is attempting to communicate with the towfish.

Running - Communication has been established and the towfish is transmitting data.

Note: If the towfish fails to start allow 30 seconds to elapse before attempting a restart.

Stopping the Towfish

To stop the towfish select Towfish > Stop. After stopping the towfish allow 30 seconds to
elapse before starting it again.

If you are acquiring a record you will be prompted to stop acquiring before the towfish is
stopped.



MaxView14

© 2011 C-MAX Ltd

3.2 Changing the range and frequency

To change the towfish range and/or  frequency select Towfish > Select Range....

The dialog shows the current range and frequency. The ranges available depend on the
type of towfish used.  Ranges shown in grey are unavailable.
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3.3 Other Towfish Functions

Altitude Control

It is important that the towfish altimeter is locked on to the seabed. If the altimeter
appears not to be locked on select Towfish > Altitude Control...

To bring up the Altitude Control dialog. Use the Force Up and Force Down buttons to
relock the altimeter. You can use the Ctrl + Up Arrow and  Ctrl + Down Arrow keys as
shortcuts for these operations.

Mute Towfish

To prevent the towfish from pinging select Towfish > Mute.

Shallow Mode

To set shallow mode select Towfish > Shallow Mode.

Gain Mode

To set the gain lock select Towfish > Gain Lock.

3.4 Using Quick Select

Pressing the Space bar will bring up the Quick Select menu.

This gives quick access to the most commonly used functions. The options available
depend on the towfish and acquisition status.

Use the Up/Down arrows to change the selection and Enter to accept to selection.

To cancel the menu press the Space bar again.
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4.1 Acquiring a record

Start the towfish

The towfish must be running before acquisition can begin. See Starting and stopping
the towfish. When the towfish is running the 'Live' window will be visible. For safety
reasons the 'Live' window will automatically be brought to the foreground within three
seconds of being hidden behind other windows. The width of the live window can be
changed by dragging the edge or corner of the window.

Start acquisition

THE DONGLE MUST BE INSERTED TO ENABLE ACQUISITION!

Select File > Acquire Record Into Project.... Choose a record name and click save to
start the acquiring. Note that a project must be opened or created before acquisition is
possible. During acquisition the status bar at the bottom of the 'Live' window displays
the number of pings acquired, the file size, the number of targets adding and the number
of position fixes received.

Stop acquisition

Select File > Stop Acquiring.

The acquired record will be added to the project.
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4.2 Towfish Layback

What is Layback?

For most surveys it is necessary for targets of interest to be able to be located and
given a geographical reference. This is usually a GPS derived navigation fix. For
MaxView to be able to calculate the position of a target the horizontal distance between
the GPS antenna and the towfish needs to be resolved. This disatnce is called the
Layback. 

Setting the Layback

Select Navigation > Layback...

When a short tow cable is being used and estimated layback can be entered. If a
counting pulley is being used and either a towfish depth sensor is fitted or a water depth
sounding input is available the layback can be calculated automatically.
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4.3 Zooming and measuring

Zooming

You can zoom up on an area of interest by dragging a zoom box using the left mouse
button. This will create a 'Zoom' window. If 'Allow multiple zoom windows' (File > Settings
> General) is selected you may have more than one window open. This is useful for
comparing areas of interest.

You can copy the image in a 'Zoom' window to the clipboard by selecting Copy Image
To Clipboard from the 'right-click' menu.

Measuring

You can measure the height of a object by right-dragging between the centre of the
object and the tip of its shadow.

 If the record has navigation data you can measure the distance between two objects by
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right-dragging between the centre of the objects.
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4.4 Following a survey line

During acquisition it can be helpful to the vessel helmsman if there is a visual indication
to assist in following a predefined survey line or lines. MaxView provides a helmsman's
display for this purpose.

Using the helmsman's display

If a survey has been pre planned by defining a series of survey lines the helmsman's
display will indicate the distance and direction from the vessel to the active survey line.
To set a survey line as active double click the line in the 'Survey Lines' tab of the project
window. The active survey line will be show in red on the plotter.
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5.1 Opening a 'View' window

If the project contains one or more records you can display a record in a 'View' window.
You can open a 'View' window by double clicking on a record in the Record tab.  If 'Allow
multiple View windows' (File > Settings > General) is selected you may have more than
one window open. You can select several records in the Records tab and click Display
Selected Records from the 'right-click' menu.

If a record is already displayed in a 'View' window that window brought to the
foreground. Records that are displayed in a 'View' window are marked with a  symbol
in the Project tab.

You can scroll through the record using the scroll bar on the right side of the 'View'
window. When the mouse is over the record image the range bar at the bottom of the
'View' window shows the distance of the mouse from the centre line. The width of a
'View' window can be changed by dragging the edge or corner of the window.
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5.2 Zooming and measuring

Zooming

You can zoom up on an area of interest by dragging a zoom box using the left mouse
button. This will create a 'Zoom' window. If 'Allow multiple zoom windows' (File > Settings
> General) is selected you may have more than one window open. This is useful for
comparing areas of interest.

You can copy the image in a 'Zoom' window to the clipboard by selecting Copy Image
To Clipboard from the 'right-click' menu.

Measuring

You can measure the height of a object by right-dragging between the centre of the
object and the tip of its shadow.

 If the record has navigation data you can measure the distance between two objects by
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right-dragging between the centre of the objects.
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5.3 Imagery options

Colour Palette

You can change the palette used to display the sonar imagery by selecting Imagery >
Palette....

Geometry

The image can be show in either uncorrected or slant range corrected geometry by
selecting Imagery > Geometry

Navigation Messages

You can overlay navigation messages on the sonar imagery by selecting Imagery >
Navigation Message.... and selecting the required filter option.
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6.1 Plotter features

The 'Plotter' window

The 'Plotter' window shows the navigation tracks of the records in the project. The track
of each record is shown as a line with the start end end points marked. Tracks of
records selected in the Records tab are shown highlighted.

During acqiusition the plotter shows the position and direction of the vessel as well as
the track of the acquiring record. The 'Plotter' window is automatically shown for projects
that have records with naviagtion tracks. The plotter can be hidden or made visible by
selecting Plotter  > Show Plotter. You can change the background colour by selecting
Plotter > Background Colour....

Zooming and scaling

You can zoom in on a section of the plotter by left-dragging a zoom box. To set the
plotter zoom to include all plotted records select Plotter > Reset Scale or click the  button
at the top left of the plotter window.

You can change the grid spacing by selecting Plotter > Grid Settings....

Using Plotter Pins

The plotter has two position markers call pins. These are used for distance measuring
and survey line generation. Double clicking on the plotter will display the fix of the
selected point and allow this position to to set as either the start pin, shown in green, or
the end pin, shown in red. You can also set the start or end pin position to the current
vessel position by selecting Planning > Copy Vessel Position To.

To measure the distance between the start and end pin select Planning > Measure >
Distance between pins.

Plotter Options

You can select the visibility of various plotter options from the Plotter menu.

Coverage - This shows the swept coverage of each record
Fixes - This shows each navigation fix as a cross on the track
Bounds - This shows the rectangular boundary around all the plotter records
Targets - This shows the position of the targets
Vessel Position - This shows the position of vessel during acquisition
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6.2 Overlaying a chart image

You can use a bitmap format image such as a marine chart or satellite image as the
background for the plotter.

You need to supply the bottom left and top right real world co-ordinates of the image so
that MaxView can geo-reference the sidescan tracks and over features over this image.

Select Plotter > Set Chart Image... and supply a filename, bottom left and top right co-
ordinate.

Note that the size of the bitmap should not exceed 1000 x 1000 pixels. Images larger
than this should be scaled down before use.
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6.3 Survey planning

It is often desirable to pre plan a survey by defining a series of lines between fixed
points that will be followed by the survey vessel at acquisition time. 

Adding a survey line manually

Selecting Planning > Add Survey Line... displays the dialog below

The co-ordinates of the start and end points can be entered by clicking the related
'Change...' button. After the start and end points have been defined the length or course
of the survey line can be altered.

Adding a survey line graphically

A survey line can be created directly from points on the plotter by setting the plotter
'Pins' (see Plotter features) at the start and end points of the line and clicking 'Paste pin
positions' in the above dialog. Alternatively you can right click on the plotter and select
'Create survey line between pins...' from the drop down menu. 

Adding parallel survey lines

Many surveys are performed as a series of parallel runs. This is a simple ways to
guarantee complete coverage of the survey area. MaxView can automatically generate
a series of parallel survey plan lines by defining and selecting a 'key' survey plan line in
the project window. Selecting Planning > Create Parallel Lines... will display the dialog
below.
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The left and right Line Count values define how many lines to the left and right of the key
line will be created. The spacing defines the distance between each new line.

Survey line lengths

Selecting a survey line or lines from the 'Survey Lines' tab of the project window will
change the colour of the line as displayed on the plotter to yellow. The total length of the
selected survey lines can be show by selecting Planning > Measure > Selected survey
lines.
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7.1 Marking Targets Offline

Adding a target

To mark a target in 'View' window double click on the object of interest

and click Create Target... .

Give the target a name and optionally, a comment, and click OK. The target will be
added to the project and shown in the Targets tab.

Removing a target

To remove a target or targets from the project select the targets in the Targets tab and
select Targets > Delete Selected Targets.
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7.2 Marking Targets Online

Adding a target

To a target in the 'Live' window double follow the same procedure as Marking Targets
Offline.

Note that the target thumbnail image is not visible for online targets.

Quick Targets

To make target marking easier during acquisition the Quick Targets can be enabled.
This feature allows the user to add a target to the Live image by double clicking on the
desired position without the 'Add Target' window appearing. The target name is pre-
defined and an auto incrementing number is appended to it. Quick Targets are enabled
by selecting Targets > Quick Targets...

Adding an event mark

A numbered event mark can be added to the acquiring record by selecting Targets >
Add Event Mark. The number will count up each time an event mark is added.

The current event mark number can be set by selecting Targets > Set Event Number.
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8.1 Connecting a GPS receiver

Most sidescan surveys will require a navigation source such as a GPS to be connected
the the system to provide position references for target and coverage.

Setting the serial port

To set the serial port and baud rate select n > Navigation > GPS Port Setup...

If the Validate NMEA Checksum box is checked messages with an incorrect checksum
are rejected.

Setting the co-ordinate system and message types

MaxView can use either lat/long or UTM type co-ordinates. To set the co-ordinate
system select Latitude\Longitude or Easting\Northing in the Grid System area.

If the Latitude\Longitude system is selected you can select which NMEA sentence types
are used.

Selecting Navigation > Message Selection... displays the dialog below.
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If the Validate NMEA Checksum box is checked messages with an incorrect checksum
are rejected.

GLL, GGA and RMC messages are used for position fixing. Other messages used by
MaxView are VTG for course and speed, HDT for heading, GSV and GSA for GPS
quality and DBT for depth.

Testing the GPS connection

You can verify that serial port setup is correct and that GPS data is being received by
MaxView using the Navigation > Message Viewer... window

This window shows the messages received from the serial port regardless of which grid
system or message types are currently selected.

GPS Fix Quality

You can check the quality of the received GPS signal by Selecting Navigation > GPS Fix
Quality... This shows the satellites in view and the Dilution Of Precision (DOP). The
lower the DOP value the better the fix quality.
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8.2 Using the CM2 Counting Pulley

Connecting the Pulley

To use the counting pulley with MaxView you must have the Counting Pulley Display
program running. See the instructions that come with the pulley on how to do this.

When the pulley is connected the count is show in the Pulley section of the MaxView
window.

To find the pulley or to reset the count to zero select Tools > Find/Reset Pulley.



Part

IX



MaxView40

© 2011 C-MAX Ltd

9.1 Converting files to Q-MIPS or XTF

To convert a CM2 sonar record to Q-MIPS or XTF format select Tools > Convert > CM2
to Q-MIPS/XTF.

The source file must be a CM2 sonar record. These files have the file extension '.cm2' .

The output file extension depends on the chosen file format. Q-MIPS files have the
extension '.dat'  and XTF file have the extension '.xtf'

Options

Skip pings until first nav fix - Checking this option causes the conversion process to skip
over the first sonar pings of the CM2 record until a navigation fix is found. This should be
checked if the output file is to be included in a mosaic.

Rewrite time code -  This option alters the time stamp that is stored with each ping. This
should only be checked if the original time stamps are corrupted.

Invert image -  This option causes the value of each sample in a ping to have its intensity
reversed.

Nav source type - This determines which type of navigation co-ordinate type to use
during the conversion. Selecting 'Lat/Long' extracts latitude and longitude values from
NMEA messages such as GLL and GGA. Selecting 'UTM' extracts northings and
eastings from valid UTM messages.

File format - Sets which output format to use.
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Notes Q-MIPS files produced by this conversion process always contain 1024 samples
per side regardless of the source file. This is because most packages do not accept Q-
MIPS files with any other number of samples.
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9.2 Converting records to Bitmap images

To convert a CM2 sonar record to a Bitmap image select Tools > Convert > CM2 to
Bitmap...

The source file must be a CM2 sonar record. These files have the file extension '.cm2' .

The output file is a Window Bitmap file with the extension '.bmp' .

Notes

This feature converts the entire record so the resulting bitmap files may be very large.
The source record must contain one sonar range only otherwise the conversion will fail.
To create a bitmap of part of a record you can you use the Trim feature to create a new
record from a section of an existing record and then convert this.
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10.1 Trimming records

The Trim feature allows you to create a new sonar record from a subset of an existing
record.

  



Index 45

© 2011 C-MAX Ltd

Index
- A -
Acquiring a record     17, 18, 21

- C -
Changing the range and frequency     14

chart     29, 30

Connecting a GPS     36

Converting files to Q-MIPS or XTF     40

Converting records to Bitmap images     42

- I -
Installing MaxView     5

Installing the STR Driver     6

- M -
Marking Targets Offline     33

Marking Targets Online     34

MaxView projects     10

- O -
Opening a 'View' window     23

Other Towfish Functions     15

overlay     29, 30

- Q -
quick select     15

- S -
Starting and stopping the towfish     13

System Requirements     5

- T -
The CM2 Counting Pulley     38

The MaxView Display     9

The MaxView Dongle     6

The Plotter window     28

Trimming records     44

- W -
What does MaxView do?     8

- Z -
Zooming and measuring     19, 24




	Installing and Running MaxView
	System Requirements
	Installing MaxView
	Installing the STR driver
	The MaxView Dongle
	Installing the Dongle driver

	Overview of MaxView
	What does MaxView do?
	The MaxView Display
	MaxView projects

	Controlling the Towfish
	Starting and stopping the towfish
	Changing the range and frequency
	Other Towfish Functions
	Using Quick Select

	Recording Sidescan Data
	Acquiring a record
	Towfish Layback
	Zooming and measuring
	Following a survey line

	Viewing Sidescan Data
	Opening a 'View' window
	Zooming and measuring
	Imagery options

	Using the Plotter window
	Plotter features
	Overlaying a chart image
	Survey planning

	Marking Targets
	Marking Targets Offline
	Marking Targets Online

	Connecting Other Sensors
	Connecting a GPS receiver
	Using the CM2 Counting Pulley

	Exporting Data
	Converting files to Q-MIPS or XTF
	Converting records to Bitmap images

	Tools
	Trimming records


